Bob!RynthidZerzelikyrAyanAerlintheNeftetgearknightsdarkisleSanctuary

AC Account Manager (Thwarg Launcher)

Plugin/Utility Releases and Community Support. Do not release software without the author's consent.
Starcrusher
Posts: 28

Re: AC Account Manager (Thwarg Launcher)

Post#71 » June 22nd, 2016, 8:39 pm

Yeah you have to copy your account and your profile(s) files to the proper ThwargLauncher directories from the ACAccountManager directories. I didn't have to re-enter anything.
1 x

User avatar
Yertle
Posts: 8

Re: AC Account Manager (Thwarg Launcher)

Post#72 » July 15th, 2016, 11:52 pm

I updated last week and ever since after I login with an Account a timer for 120 seconds starts, then even if it logs in successfully (and I log a character in even) the Launcher will login with that same account again. What's up with that?

Thanks!
1 x
Yertle of Morningthaw

darksky602
Posts: 8

Re: AC Account Manager (Thwarg Launcher)

Post#73 » August 19th, 2016, 3:52 am

Switched up laptops and put Thwarg Launcher on the new one. I am running into corrupted portals on the new install, but only in guant bosses so far. I go in the room and get a black screen. I can still portal out. Some accounts can see the entire room and door, others are seeing 1/4 of the room and still fighting.

Replaced portal.dat twice, no effect. If anyone has any ideas let me know please. If I figure it out I will post here just in case others run across it.
1 x

Joeblow8579
Posts: 67

Re: AC Account Manager (Thwarg Launcher)

Post#74 » August 19th, 2016, 8:48 am

I've never been able to get Thwarg's Launcher to work right for me. I even set it to use a different launch path for each account (thereby using different portal.dat files for each client, yet I still get all sorts of weird behavior. Most commonly it will launch one client fine but then hang there because the second one is trying to use the same set of ports or something. I went back to using Drakier's, which is crusty and old and kind of irritating but at least works consistently and predictably with my 6 accounts.
1 x

User avatar
HellsWrath
Site Admin
Posts: 388

Re: AC Account Manager (Thwarg Launcher)

Post#75 » August 19th, 2016, 11:22 am

Joeblow8579 wrote:I've never been able to get Thwarg's Launcher to work right for me. I even set it to use a different launch path for each account (thereby using different portal.dat files for each client, yet I still get all sorts of weird behavior. Most commonly it will launch one client fine but then hang there because the second one is trying to use the same set of ports or something. I went back to using Drakier's, which is crusty and old and kind of irritating but at least works consistently and predictably with my 6 accounts.


Did you add the magfilter.dll from the Thwarglauncher folder to Decal? Other versions of magfilter will not suffice.

You can set specific ports per client by setting up a different UserPreferences.ini for each, the same way you did for different LaunchPaths. Look at the top in the UserFile.
1 x

Pol
Posts: 4

Re: AC Account Manager (Thwarg Launcher)

Post#76 » August 21st, 2016, 9:19 am

I have a problem......
Frist I luv my Twarg launcer hehehe

Today I was playing and my computer gave a blue screen :( Using Win 10
After reboot I tried to get in game again using the launcer.
It say Error: check logfile.
To be honest, I have no idea how to read that
So I unstalled Twarg and reinstalled, but I get the same message. I have no idea what is wrong so I post the logfile and hope anyone can help me to tell me what is wrong.

Time (UTC): 8/21/2016 12:49:46 PM
OS: Microsoft Windows 10 Pro 64-bit
Culture: en-US
AssemblyVer: 3.2.4.0
2016-08-21 12:49:47: * Fatal Exception: System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: '.', hexadecimal value 0x00, is an invalid character. Line 12, position 1. (C:\Users\marjan.SKYNET.000\AppData\Local\ThwargLauncher\ThwargLauncher.exe_Url_bqk2rre1d323thx23pno1oswirdgaaqz\3.2.4.0\user.config line 12) ---> System.Xml.XmlException: '.', hexadecimal value 0x00, is an invalid character. Line 12, position 1.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
at System.Xml.XmlTextReaderImpl.ParseText(Int32& startPos, Int32& endPos, Int32& outOrChars)
at System.Xml.XmlTextReaderImpl.ParseText()
at System.Xml.XmlTextReaderImpl.ParseElementContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlTextReader.Read()
at System.Xml.XmlTextReaderImpl.Skip()
at System.Xml.XmlTextReader.Skip()
at System.Configuration.XmlUtil.StrictSkipToNextElement(ExceptionAction action)
at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps)
at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps)
at System.Configuration.BaseConfigurationRecord.ScanSections(XmlUtil xmlUtil)
at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
--- End of inner exception stack trace ---
at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
--- End of inner exception stack trace ---
at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
at System.Configuration.Internal.InternalConfigRoot.OnConfigRemoved(InternalConfigEventArgs e)
at System.Configuration.Internal.InternalConfigRoot.RemoveConfigImpl(String configPath, BaseConfigurationRecord configRecord)
at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String sectionName)
at System.Configuration.ConfigurationManager.GetSection(String sectionName)
at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
at System.Configuration.SettingsBase.get_Item(String propertyName)
at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
at ThwargLauncher.Properties.Settings.get_NeedsUpgrade()
at ThwargLauncher.MainWindow.MigrateSettingsIfNeeded()
at ThwargLauncher.MainWindow..ctor(MainWindowViewModel mainWindowViewModel, GameSessionMap gameSessionMap, GameMonitor gameMonitor)
at ThwargLauncher.AppCoordinator.ShowMainWindow()
at ThwargLauncher.AppCoordinator..ctor()
at ThwargLauncher.App.OnStartup(StartupEventArgs e)
at System.Windows.Application.<.ctor>b__1_0(Object unused)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
at System.Windows.Threading.DispatcherOperation.InvokeImpl()
at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at MS.Internal.CulturePreservingExecutionContext.Run(CulturePreservingExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Threading.DispatcherOperation.Invoke()
at System.Windows.Threading.Dispatcher.ProcessQueue()
at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Int32 numArgs)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.UnsafeNativeMethods.DispatchMessage(MSG& msg)
at System.Windows.Threading.Dispatcher.PushFrameImpl(DispatcherFrame frame)
at System.Windows.Threading.Dispatcher.PushFrame(DispatcherFrame frame)
at System.Windows.Application.RunDispatcher(Object ignore)
at System.Windows.Application.RunInternal(Window window)
at System.Windows.Application.Run(Window window)
at ThwargLauncher.App.Main()


Thanks in advange
Pol
1 x
It costs nothing to be nice

Pol
Posts: 4

Re: AC Account Manager (Thwarg Launcher)

Post#77 » August 21st, 2016, 12:00 pm

Problem solved!

The config file was empty after line 12. Somehow it went away with the crash.
I replaced it...tada! It works again

Pol
1 x
It costs nothing to be nice

Almedes
Posts: 15

Re: AC Account Manager (Thwarg Launcher)

Post#78 » August 28th, 2016, 1:52 am

Ok, I have been having issues, and I have been able to replicate the problem several times now. When I go into a dungeon, or portal I have never been in before, and I have to do a download, the client crashes, or I get a black screen from a corrupted portal.dat file. Now this only happens when I am running more than one client. If am only running one client, the download happens, and the dungeon or portal download happens fine. Every time this happens, I have to revert back to a back up portal.dat (which I have to do on a constant basis) and start all over. What is strange about this, is I didn't have this problem when I was using version 2.2.8 and running Windows 7. I upgraded to version 3.2.4 (didn't run any of the versions in between), and shortly there after I upgraded to Windows in late July. I don't remember it happening in between that time, but I can't say for sure. I noticed this when I tried to take my crew into VSlayer. I had never done the dungeon before, and that was the first time I remember for certain it crashed. I thought it was something on my end. I have uninstalled AC, Decal (then run the Decal Registry Cleaner), Thwarg, and DX9c, and then reinstalled everything from scratch. I have the current stable video drivers, and no other games have I had an issue (haven't any issues with any programs). I have been able to replicate it with and without Decal running, so it doesn't appear to be a Decal issue. It is at the exact moment another client enters the same portal/dungeon that my primary account has went through, and if the primary account has not finished the download that the client crashes. If the other clients hit portal right at the end of the download I get a black screen. Again, if I go through it with primary account first, and complete the download, then client doesn't crash when I have other accounts go through it. I have duplicated it in Deewains and Vslayer. I have even tried changing permissions on the .dat files (found on thread here on this forum) and it didn't change a thing. I also run 8 clients, on dual displays. While I am fairly certain this is an issue with the way Thwarg handles the .dat files, I am not 100%, it could be a Win 10 issue, and it maybe an issue that can't be fixed. I know there are a few on Morningthaw that have seemed to have the same issue, but nobody knows why, or could pin point it. They just replace the .dat files, and move along. I have been doing the same, but after redoing my .dat files 3 times in 2 days, I finally took the time to try to figure out why.

If it helps any, here is my System, and I am running all stable release drivers.

Intel 6600k
24 Gig DDR4
335 Intel SSD
GTX 960
MSI z170 MB
Win 10
1 x

User avatar
Thwargle
Posts: 25

Re: AC Account Manager (Thwarg Launcher)

Post#79 » August 28th, 2016, 4:21 pm

There appears to be several reasons for this, but I have yet to track down exactly why this happens. One suggestion is to download the nearly complete .dat files. They are hosted on silo's website: http://www.silostoybox.com/thwarg-launcher.php. In the blue there is a "Click here for .dat files".

The other option is to set dedicated file directories for each client. This is less desirable. I would suggest downloading the .dat files and working with that to see if it has solved your issue. This will make it so that you have the dungeon data, and the separate clients won't be fighting to read/write to the same file at the same time.

I believe it's some sort of race condition, but i've never been able to reproduce it on any of my machines, so i can't help fix the issue.


My launcher allows you to configure a separate installation directory per client. If you need to do that and can't figure it out in the .config file, let me know and I can help with that as well.
1 x

Almedes
Posts: 15

Re: AC Account Manager (Thwarg Launcher)

Post#80 » August 29th, 2016, 6:15 pm

I will try the .dat files (didn't know there was an almost completed set), and if I still have issues, I probably will end up doing folders for each account. I will let you know what the results are.
1 x

Return to “Utilities and Plugins”

Who is online

Users browsing this forum: No registered users and 1 guest

cron

Login  •  Register